使用opennmt-tf遇到的问题

1. nvidia-smi报错

错误详情:NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running
原因:NVIDIA驱动是在低版本的时候安装,由于系统更新,内核版本升级导致NVIDIA无法应用在高内核版本, 所以,说明是内核版本的问题,选择低版本的内核即可
解决:修改Ubuntu默认开机启动的内核版本
命令:

  1. 查看当前ubuntu使用的内核版本
uname -r 

输出:4.15.0-1035-aws

  1. 查看所有的内核版本
grep -A100 submenu  /boot/grub/grub.cfg |grep menuentry 

输出:


image.png

查看之前的内核版本:

dpkg -l | tail -n +6| grep -E 'linux-image-[0-9]+'| grep -Fv $(uname -r)
sudo dpkg --get-selections |grep linux-image
  1. 修改系统启动内核版本
sudo cp /etc/default/grub /etc/default/grub.bak //备份
sudo vim /etc/default/grub

GRUB_DEFAULT=0

修改为:

GRUB_DEFAULT="gnulinux-advanced-bbf64c6d-bc15-4ae0-aa4c-608fd9820d95>gnulinux-4.15.0-1021-aws-advanced-bbf64c6d-bc15-4ae0-aa4c-608fd9820d95"

(注:>前面 代表主菜单的第二项Advanced options for Ubuntu id;>后面代表项目下面对应的子菜单里面kernel id;)

  1. 修改后保存退出,执行:
sudo update-grub
  1. 重新启动,现在应该默认启动旧的内核版本。
    EC2:在UI上reboot,千万不能用sudo reboot,要不实例起不来
    Ubuntu: sudo reboot

  2. 查看内核版本
    $ uname -r
    4.15.0-42-generic

参考:http://forum.ubuntu.org.cn/viewtopic.php?t=486436
https://blog.csdn.net/sinat_23619409/article/details/85220561

https://meetrix.io/blog/aws/changing-default-ubuntu-kernel.html

https://aws.amazon.com/cn/premiumsupport/knowledge-center/revert-stable-kernel-ec2-reboot/

https://docs.aws.amazon.com/zh_cn/AWSEC2/latest/UserGuide/ec2-instance-reboot.html

2. python2不支持eval

创建虚拟环境时,默认使用python3
mkvirtualenv py36-opennmt-tf-2 –python=/usr/bin/python3.6

出处:https://www.jianshu.com/p/16f4595c4041

剑与家园下载
「点点赞赏,手留余香」

    还没有人赞赏,快来当第一个赞赏的人吧!
0 条回复 A 作者 M 管理员
    所有的伟大,都源于一个勇敢的开始!
欢迎您,新朋友,感谢参与互动!欢迎您 {{author}},您在本站有{{commentsCount}}条评论