单细胞转录组中 UMAP的安装 – Python量化投资

单细胞转录组中 UMAP的安装

Installing
UMAP depends upon scikit-learn, and thus scikit-learn’s dependencies such as numpy and scipy. UMAP adds a requirement for numba for performance reasons. The original version used Cython, but the improved code clarity, simplicity and performance of Numba made the transition necessary.

Requirements:

(1) numpy
(2) scipy
(3) scikit-learn
(4) numba

Install Options

Conda install, via the excellent work of the conda-forge team:

conda install -c conda-forge umap-learn

The conda-forge packages are available for linux, OS X, and Windows 64 bit.

PyPI install, presuming you have numba and sklearn and all its requirements (numpy and scipy) installed:

pip install umap-learn
If pip is having difficulties pulling the dependencies then we’d suggest installing the dependencies manually using anaconda followed by pulling umap from pip:

conda install numpy scipy
conda install scikit-learn
conda install numba
pip install umap-learn

For a manual install get this package:

wget https://github.com/lmcinnes/umap/archive/master.zip
unzip master.zip
rm master.zip
cd umap-master
Install the requirements

sudo pip install -r requirements.txt
or

conda install scikit-learn numba

Install the package

python setup.py install

https://www.jianshu.com/p/1b6758656647

「点点赞赏,手留余香」

    还没有人赞赏,快来当第一个赞赏的人吧!
0 条回复 A 作者 M 管理员
    所有的伟大,都源于一个勇敢的开始!
欢迎您,新朋友,感谢参与互动!欢迎您 {{author}},您在本站有{{commentsCount}}条评论