TensorFlow深度学习1–TensorFlow2.0及安装

        2019年下半年, tensorflow更新到了2.0版本,对Keras API进行了兼容,使用起来更加方便,可以快速搭建神经网络进行模型计算。最近几年陆续也利用工作之余,学习过一些机器学习和神经网络的书籍,许多内容没有吃透,因此准备整理下之前的材料,作为学习笔记,也和大家一起沟通学习。

        TensorFlow虽然在运算速度上并不一定最快,但它有以下优点:

        1,流行度高:相比较于其它开源工具keras、MNNet、PyTorch来说流行度更高,因此在学习资料、数据集及案例也会更多,而且随着开源生态的发展会出现更多的算法。

        2,工业级工具,tensorflow是google内部机器学习工具,通过支持多GPU以及分布式部署方式处理海量数据,分布式部署的模式,将一个训练任务拆分成多个小任务,配置到不同的计算机上完成协同运算,这样使用计算机群运算来代替单机运算,提高效率。

3,即有高阶TF.KERAS API方便搭建常用模型,也有低阶的函数可以扩展及优化。也就是即适合初学者,也适合资深AI开发者。

         首先介绍下TensorFlow2.0的安装,由于GPU版本对硬件要求较高,CPU版本作为学习也足够。以下步骤为基于windows CPU版本安装步骤,mac和linux版本安装类似,GPU版本安装可见官网。

        (1)Tensorflow依赖Microsoft Visual C++ 2015 Redistributable Update 3,需要先行安装,以下是安装链接,下载后进行安装;

https://www.microsoft.com/zh-cn/download/details.aspx?id=53840

        (2)安装anaconda:可自行百度,安装最新版本;安装好后在命令行(CMD)输入命令查看目前的env。

conda info –envs 

        (3)新建环境,其中名称为 TF_2C , pip 为19.3版本(需要19.0以上版本,anaconda默认为pip 9,所以需要指定版本)

conda create -n TF_2C python=3.6 pip=19.3

环境分析完后,输入Y进入安装。

        (4)激活新建的环境 :conda activate TF_2C

        (5)安装tensorflow 2 ,这里使用清华的镜像,豆瓣镜像还没有2.0版本: 

pip install tensorflow==2.0.0 -i https://pypi.tuna.tsinghua.edu.cn/simple

安装中可能存在的问题:

1)报错:ModuleNotFoundError: No module named    ‘setuptools._deprecation_warning’。更新setuptools组件,如上图在env中输入即可:pip install –upgrade setuptools

2)缺少库,XXX depreciated 等问题,检查是否安装了 Microsoft Visual C++ 2015 Redistributable Update 3。

        (6)验证,在TF_2C 环境中输入python , 并打印TensorFlow版本,出现版本后就说明安装成功了。

三、Eclipse配置

因习惯eclipse的开发环境,通过eclipse可以不用切换开发工具,Eclipse的Pydev插件安装可参考https://www.cnblogs.com/xdzy/p/9458635.html

在建立project中可以选择和配置环境,在本文中选择anaconda下新建的TF_2C环境下的python.exe。配置完成后,打印版本号验证下是否选择正确


https://www.jianshu.com/p/dae4d8df09a5

「点点赞赏,手留余香」

    还没有人赞赏,快来当第一个赞赏的人吧!
0 条回复 A 作者 M 管理员
    所有的伟大,都源于一个勇敢的开始!
欢迎您,新朋友,感谢参与互动!欢迎您 {{author}},您在本站有{{commentsCount}}条评论